Working with module ios_config in ansible and use src parameter

The src parameter allows you to specify the path to a configuration file or configuration template to be loaded on the device.

This parameter is mutually exclusive with lines (that is, either lines or src can be specified).

Example playbook ios_config_src.yml:

---
- name: Run cfg commands on router
  hosts: 192.168.0.22

  tasks:

    - name: Config ACL
      ios_config:
        src: templates/acl_cfg.txt

The templates/acl_cfg.txt file contains the following configuration:

ip access-list extended IN_to_OUT
 permit tcp 192.168.2.0 0.0.0.255 any eq www
 permit tcp 192.168.2.0 0.0.0.255 any eq 22
 permit icmp any any
 deny   ip any any

We delete this ACL on the router if it remains from the previous sections, and start the playbook:

$ ansible-playbook ios_config_src.yml -v

Now the ACL is configured on the router:

R1#sh run | s access
ip access-list extended IN_to_OUT
 permit tcp 192.168.2.0 0.0.0.255 any eq www
 permit tcp 192.168.2.0 0.0.0.255 any eq 22
 permit icmp any any
 deny   ip any any

If you run the playbook again, there will be no change, since this parameter is also idempotent:

$ ansible-playbook ios_config_src.yml -v

How to use Jinja2 Template with src parameter?

Jinja2 template can be specified in src parameter.

Temlate example (file templates/ospf.j2):

router ospf 1
 router-id {{ mgmnt_ip }}
 ispf
 auto-cost reference-bandwidth 10000
{% for ip in ospf_ints %}
 network {{ ip }} 0.0.0.0 area 0
{% endfor %}

Template example (file templates/ospf.j2):

The template uses two variables:

  • mgmnt_ip – IP address to be used as router-id
  • ospf_ints – list of IP addresses of interfaces on which to enable OSPF

To configure OSPF on three routers, you need to be able to use different values for these variables for different devices. For such tasks, files with variables in the host_vars directory are used.

In the host_vars directory, you need to create the following files (if they have not already been created):

File host_vars/192.168.0.22:

---

hostname: R1
mgmnt_loopback: 100
mgmnt_ip: 10.0.0.1
ospf_ints:
  - 192.168.0.22
  - 10.0.0.1
  - 10.255.1.1

File host_vars/192.168.0.23:

---
hostname: R2
mgmnt_loopback: 100
mgmnt_ip: 10.0.0.2
ospf_ints:
  - 192.168.0.23
  - 10.0.0.2
  - 10.255.2.2

File host_vars/192.168.0.24:

---
hostname: R3
mgmnt_loopback: 100
mgmnt_ip: 10.0.0.3
ospf_ints:
  - 192.168.0.24
  - 10.0.0.3
  - 10.255.3.3

Now you can create playbook ios_config_src_jinja.yml:

---

- name: Run cfg commands on router
  hosts: cisco-routers

  tasks:

    - name: Config OSPF
      ios_config:
        src: templates/ospf.j2

Since Ansible will find the variables in the host_vars directory itself, they do not need to be specified. You can immediately launch the playbook:

$ ansible-playbook ios_config_src_jinja.yml -v

OSPF is now configured on all routers:

R1#sh run | s ospf
router ospf 1
 router-id 10.0.0.1
 ispf
 auto-cost reference-bandwidth 10000
 network 10.0.0.1 0.0.0.0 area 0
 network 10.255.1.1 0.0.0.0 area 0
 network 192.168.0.22 0.0.0.0 area 0

R2#sh run | s ospf
router ospf 1
 router-id 10.0.0.2
 ispf
 auto-cost reference-bandwidth 10000
 network 10.0.0.2 0.0.0.0 area 0
 network 10.255.2.2 0.0.0.0 area 0
 network 192.168.0.23 0.0.0.0 area 0

router ospf 1
 router-id 10.0.0.3
 ispf
 auto-cost reference-bandwidth 10000
 network 10.0.0.3 0.0.0.0 area 0
 network 10.255.3.3 0.0.0.0 area 0
 network 192.168.0.24 0.0.0.0 area 0

If you run the playbook again, there will be no changes:

What parameters are combined with src?

The src option is compatible with the following options:

  • backup
  • config
  • defaults
  • save

Leave a Reply

Your email address will not be published. Required fields are marked *